summaryrefslogtreecommitdiff
path: root/rebuildpkgs.in
diff options
context:
space:
mode:
Diffstat (limited to 'rebuildpkgs.in')
-rw-r--r--rebuildpkgs.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/rebuildpkgs.in b/rebuildpkgs.in
index a0e8250..4f4f98b 100644
--- a/rebuildpkgs.in
+++ b/rebuildpkgs.in
@@ -21,6 +21,7 @@ fi
# Source makepkg.conf; fail if it is not found
if [[ -r '/etc/makepkg.conf' ]]; then
+ # shellcheck source=makepkg-x86_64.conf
source '/etc/makepkg.conf'
else
die '/etc/makepkg.conf not found!'
@@ -28,8 +29,10 @@ fi
# Source user-specific makepkg.conf overrides
if [[ -r "${XDG_CONFIG_HOME:-$HOME/.config}/pacman/makepkg.conf" ]]; then
+ # shellcheck source=/dev/null
source "${XDG_CONFIG_HOME:-$HOME/.config}/pacman/makepkg.conf"
elif [[ -r "$HOME/.makepkg.conf" ]]; then
+ # shellcheck source=/dev/null
source "$HOME/.makepkg.conf"
fi
@@ -50,6 +53,7 @@ bump_pkgrel() {
pkg_from_pkgbuild() {
# we want the sourcing to be done in a subshell so we don't pollute our current namespace
export CARCH PKGEXT
+ # shellcheck source=PKGBUILD.proto
(source PKGBUILD; echo "$pkgname-$pkgver-$pkgrel-$CARCH$PKGEXT")
}