summaryrefslogtreecommitdiff
path: root/rebuildpkgs.in
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@parabola.nu>2017-03-28 19:20:11 -0400
committerLuke Shumaker <lukeshu@parabola.nu>2017-05-05 18:28:56 -0400
commit518a22f386ccb5968dce85490278494e058995b1 (patch)
tree814a53b965cfcc26ededc9fd9dd48c52ac4e2432 /rebuildpkgs.in
parent0beccef4ac405fdefdafba5b9ac6e7962b1610d2 (diff)
downloaddevtools32-518a22f386ccb5968dce85490278494e058995b1.tar.xz
Add `# shellcheck` directives to quiet shellcheck, add PKGBUILD.protolukeshu/to-upstream/pre-release-20170505
The added PKGBUILD.proto file is so that shellcheck can know know what to expect that a PKGBUILD sets.
Diffstat (limited to 'rebuildpkgs.in')
-rw-r--r--rebuildpkgs.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/rebuildpkgs.in b/rebuildpkgs.in
index a0e8250..4f4f98b 100644
--- a/rebuildpkgs.in
+++ b/rebuildpkgs.in
@@ -21,6 +21,7 @@ fi
# Source makepkg.conf; fail if it is not found
if [[ -r '/etc/makepkg.conf' ]]; then
+ # shellcheck source=makepkg-x86_64.conf
source '/etc/makepkg.conf'
else
die '/etc/makepkg.conf not found!'
@@ -28,8 +29,10 @@ fi
# Source user-specific makepkg.conf overrides
if [[ -r "${XDG_CONFIG_HOME:-$HOME/.config}/pacman/makepkg.conf" ]]; then
+ # shellcheck source=/dev/null
source "${XDG_CONFIG_HOME:-$HOME/.config}/pacman/makepkg.conf"
elif [[ -r "$HOME/.makepkg.conf" ]]; then
+ # shellcheck source=/dev/null
source "$HOME/.makepkg.conf"
fi
@@ -50,6 +53,7 @@ bump_pkgrel() {
pkg_from_pkgbuild() {
# we want the sourcing to be done in a subshell so we don't pollute our current namespace
export CARCH PKGEXT
+ # shellcheck source=PKGBUILD.proto
(source PKGBUILD; echo "$pkgname-$pkgver-$pkgrel-$CARCH$PKGEXT")
}